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Flow appears as "New" when it exists in the target org

A short description of why a Flow might appear as 'New' in a Gearset comparison despite the same Flow existing in the target org.

Written by Chris Mead

Summary

If Flows appear as New in a comparison, but they already exist in the target org, this can be caused by a Salesforce Metadata API limit.

Cause

Salesforce enforces a hard limit of 10,000 records when retrieving Flow versions over the Metadata API using a wildcard. If an org has more than 10,000 records across Flow versions in total, the retrieval fails silently for the affected Flows.

This is a Salesforce Metadata API limitation, which unfortunately can make Flows un-deployable. However, you can work around this by deleting obsolete Flow versions in the target.

It's not possible to delete specific versions of a Flow via the metadata API, so this must be done in the target manually.

How to confirm this is the cause

  1. Use Workbench to retrieve Flow metadata from the affected org with the same user account used in Gearset.

  2. If Workbench also fails to return the Flow, this confirms the issue is with the Metadata API, not Gearset.

  3. Check how many total Flow versions exist in the org for that Flow. Flows that have more than 10,000 versions hit this limit and do not retrieve in a comparison.

For a more detailed guide on how to use Workbench to replicate retrieval issues, see our documentation here

How to fix it

  • Delete obsolete Flow versions to bring the flow under the 10,000 limit.

  • Removal unused Flows from the org to bring this limit down.

    There is no other workaround for this issue at this point in time. If you have any queries or concerns, please feel free to reach out to us via our in-app chat.

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