This analyzer helps with API versioning problems when deploying Apex components.

What triggers this problem analyzer?

Trying to deploy an Apex component that has a newer API version than any other components in the target (e.g. an Apex class on v44 when everything else in the target is on v43).

When this occurs, Gearset will warn you about the API version mismatch along with a list of the Apex components that have the version compatibility problems.

What problem is it solving?

Deploying components with a newer API version than is compatible with the target environment can cause your deployments to fail.

How does it work?

The analyzer will present the list of components causing the compatibility issues but will not automatically update any of the components for you or exclude these items from your deployment. 

You will need to manually edit the Apex components or make changes to the API versioning in the target environment to resolve these issues.

Did this answer your question?